Pages Help

Dependency versions

GitHub Pages uses the following dependencies and versions:

Dependency Version
jekyll 3.4.3
activesupport 4.2.7
github-pages-health-check 1.3.3
github-pages 134
html-pipeline 2.5.0
jekyll-avatar 0.4.2
jekyll-coffeescript 1.0.1
jekyll-default-layout 0.1.4
jekyll-feed 0.9.2
jekyll-gist 1.4.0
jekyll-github-metadata 2.3.1
jekyll-mentions 1.2.0
jekyll-optional-front-matter 0.1.2
jekyll-paginate 1.1.0
jekyll-readme-index 0.1.0
jekyll-redirect-from 0.12.1
jekyll-relative-links 0.4.0
jekyll-sass-converter 1.5.0
jekyll-seo-tag 2.2.0
jekyll-sitemap 1.0.0
jekyll-swiss 0.4.0
jekyll-theme-architect 0.0.4
jekyll-theme-cayman 0.0.4
jekyll-theme-dinky 0.0.4
jekyll-theme-hacker 0.0.4
jekyll-theme-leap-day 0.0.4
jekyll-theme-merlot 0.0.4
jekyll-theme-midnight 0.0.4
jekyll-theme-minimal 0.0.4
jekyll-theme-modernist 0.0.4
jekyll-theme-primer 0.1.8
jekyll-theme-slate 0.0.4
jekyll-theme-tactile 0.0.4
jekyll-theme-time-machine 0.0.4
jekyll-titles-from-headings 0.1.5
jemoji 0.8.0
kramdown 1.13.2
liquid 3.0.6
listen 3.0.6
minima 2.0.0
nokogiri 1.7.1
rouge 1.11.1
ruby 2.3.3
safe_yaml 1.0.4
sass 3.4.23

For a history of dependency changes, see the past releases.

Programmatic access

Want a more programmatic way to keep your local version of Jekyll up to date? All dependencies are bundled within the GitHub Pages Ruby gem, or are available programmatically via pages.github.com/versions.json