Pages Help

Dependency versions

GitHub Pages uses the following dependencies and versions:

Dependency Version
jekyll 3.9.5
github-pages-health-check 1.18.2
github-pages 231
html-pipeline 2.14.3
jekyll-avatar 0.8.0
jekyll-coffeescript 1.2.2
jekyll-commonmark-ghpages 0.4.0
jekyll-default-layout 0.1.5
jekyll-feed 0.17.0
jekyll-gist 1.5.0
jekyll-github-metadata 2.16.1
jekyll-include-cache 0.2.1
jekyll-mentions 1.6.0
jekyll-optional-front-matter 0.3.2
jekyll-paginate 1.1.0
jekyll-readme-index 0.3.0
jekyll-redirect-from 0.16.0
jekyll-relative-links 0.6.1
jekyll-remote-theme 0.4.3
jekyll-sass-converter 1.5.2
jekyll-seo-tag 2.8.0
jekyll-sitemap 1.4.0
jekyll-swiss 1.0.0
jekyll-theme-architect 0.2.0
jekyll-theme-cayman 0.2.0
jekyll-theme-dinky 0.2.0
jekyll-theme-hacker 0.2.0
jekyll-theme-leap-day 0.2.0
jekyll-theme-merlot 0.2.0
jekyll-theme-midnight 0.2.0
jekyll-theme-minimal 0.2.0
jekyll-theme-modernist 0.2.0
jekyll-theme-primer 0.6.0
jekyll-theme-slate 0.2.0
jekyll-theme-tactile 0.2.0
jekyll-theme-time-machine 0.2.0
jekyll-titles-from-headings 0.5.3
jemoji 0.13.0
kramdown-parser-gfm 1.1.0
kramdown 2.4.0
liquid 4.0.4
minima 2.5.1
nokogiri 1.15.5
rouge 3.30.0
ruby 2.7.4
safe_yaml 1.0.5
sass 3.7.4

For a history of dependency changes, see the past releases.

Programmatic access

Want a more programmatic way to keep your local version of Jekyll up to date? All dependencies are bundled within the GitHub Pages Ruby gem, or are available programmatically via pages.github.com/versions.json

Last updated 2024-05-24 12pm +0000.